Memory

Had a very eventful weekend, and my entire Sunday was taking up trying to figure out a weird symptom on my linux installation.

In the weeks leading up to today, I used to get strange behaviour from my Fedora box. The behaviour resulting in an error being detected by the ABRT tool, regarding a null reference. Sunday, my laptop conked out and refused to startup. I tried reinstalling Fedora, Debian, Mint, openSUSE, and even OpenMandriva — none of them could complete the installation. They either failed with error part way through, or hung completely.

I decided to try installing Windows XP over everything. That failed with an IRQ LESS THAN OR EQUAL TO blue screen. Then I tried Windows 7. That installation succeeded, and I started running updates. Then it blue screened me again. This time MEMORY_MANAGEMENT was the message. Hmmm. So, could it be that one of my memory chips was dodgy? That would account for why it was intermittent. I have 2x 2GB chips in my laptop, so I took both out and rebooted. No splash screen. Good. That’s expected.

Put in one of the chips. Booted, BIOS showed 2GB. Good, that’s OK.

Took it out and put in the other 2GB. No splash screen. Looks like that’s the dodgy one. I dug out my 1GB from when I got my laptop originally, and put that back into the other slot, so I get a 3GB installation. Checked boot. Splash screen displayed. Good. So I then ran a BIOS memory check, and all 3GB passed.

So then I decided, maybe I should try doing a restore, in case the dodgy memory was the cause of my failure to restore previously. It worked fine, so now I’m back up with my previous setup. 😀

Cause: Faulty 2GB memory