UK and US Governments Warn: ‘Don’t Use Internet Explorer’

Something I’ve been saying for a LONG time…

Linux News

Don’t use Internet Explorer’ — that’s the warning being given by the US and UK governments this week after a severe security flaw affecting the browser was detected. 

Both countries are advising citizens who are running Microsoft Windows to switch to an alternative web browser, such as Opera, Mozilla Firefox or Google Chrome, until the vulnerability has been fixed.

Internet Explorer 6 through 11 — released on Windows 7 and 8 last year — are all confirmed to be affected.

For XP Users It Gets Worse

News of the vulnerability can’t have come at a worse time for those still running Windows XP.

With Microsoft officially ending support for it in April this year, even when a fix for this issue is released the update won’t be made available to the estimated 125 million hold-outs still running the aged OS.

As such the advice from the US and UK computer security agencies is even more stark: don’t use the…

View original post 17 more words